Scrapy存入MySQL驱动安装及问题:Could not find …distribution found for MySQLdb…

时间:2018-01-29 16:18:16作者:scrapy中文网阅读:

网上很多关于Scrapy存入MySQL的教程,都会发现又这么一个包的引入:
import MySQLdb
import MySQLdb.cursors
聪明的你或许已经算到,需要安装MySQLdb,所以你就在命令行输入:
pip install MySQLdb
但遗憾的是,你发现,出现了下面的错误:

 Could not find a version that satisfies the requirement MySQLdb (from versions: )No matching distribution found for MySQLdb 

几个意思?原来是没有这么一个包,找了原因发现MySQLdb只只支持到python3.4,因此,如果你是python3.5+的用户,那肯定找不到这么一个包,那如何是好?

其实,python3.5以上的用户,可以安装另外一个mysql驱动:pymysql(点击下载)

下载之后解压,然后进入解压目录(快捷方式:选中解压后的目录,按住shift+右键,此处打开命令行),然后运行如下命令安装:
python setup.py install
好了,那接下来看如何引入:
import pymysql.cursors
python3.5以上mysql便按如上方法安装mysql驱动!

python3.4以下直接:
pip install MySQLdb


评论去哪里了?

由于搜狐畅言广告越来越丧心病狂,用它一个评论,半个网页都被它占领,感觉已经把灵魂出卖给了魔鬼!SO,为了息众怒小编只能暂且关闭评论,若您实在想找我说话,欢迎关注公众号,给我留言,么么哒!

相关文章